Deconz und homebridge

  • Hallo Zusammen,


    nachdem in meinem HomeKit meine Lampen und Sensoren nicht mehr reagieren, hab ich mich für ein neuaufsetzen entschieden. In meine bis vor kurzem funktionierenden Version hatte ich das vorkonfigurierte Image von Phoscon heruntergeladen und installiert.


    Für die Neuinstallation habe ich das aktuelleste Raspian heruntergeladen und homebridge nach der Anleitung hier installiert. Hat alles prima geklappt. Nun benötige ich ja deconz, weil ich das Aufsteckmodul von Dresden Elektronik benutze und habe deconz installiert.

    Irgendetwas ist schief gelaufen. Ich komme nicht mehr auf das Homebridge Interface, aber deconz bzw. Die Integration von Sensoren funktioniert.


    Ich glaube, mir ist der Gesamtzusammenhang noch nicht klar. Wie arbeiten deconz und die Plug ins und homebridge zusammen? Ich würde es inhaltlich gern verstehen und nicht nur die Befehle reinpacken. Hat jemand Zeit, dazu ein paar Sätze zu schreiben und mir die Reihenfolge der Installationen zu erklären?


    Vielen Dank für Eure Unterstützung!


    viele Grüße

  • Ich versuche mich mal in einer Antwort für Dich:

    Für mein Verständnis ist Deconz das Programm welches auf dem Pi läuft und die Phoscon-Bridge.

    Deconz muss zwingend auf dem Pi laufen.

    Das ganze funktioniert headless oder mit Gui. Das ist auf der Pi-Seite, aus meiner Sicht, aber eher etwas für Profis.

    Die Phoscon-App, bei mir von Windows 10 aus gestartet, ist das "Verwaltungswerkzeug" um Lampen, Räume usw. zu integrieren und das Phoscon-Gateway zu managen.

    Die App wird aufgerufen (Windows) mit "http://phoscon.de/pwa/".

    Die Deconz-Installation ist auf den Supportseiten gut beschrieben.

    Einzig das Einstellen des Autostart auf dem Pi ist etwas versteckt.

    Als Anhaltspunkt nachfolgend eine Anleitung die ich persönlich gestern erst erfolgreich angewandt habe:


    Das alles natürlich ohne Anspruch auf Vollständigkeit, bzw. Funktion.

    Bei mir hats so funktioniert!

  • hallo und vielen Dank erstmal.

    Die Theorie ist mir soweit klar- wenn ich jetzt die Neuinstallation noch mal angehe, dann nach folgenden Schritten:


    - Image für den PI

    - deconz nach Anleitung von der Phoscon Seite

    - homebridge nach der Anleitung hier im Forum?


    scheinbar hat dann aber die Verknüpfung zwischen homebridge und Phoscon bei mir nicht hingehauen oder die Reihenfolge der Installation. Hast Du noch ein paar Hinweise für die Bearbeitung der Config.json in Bezug auf Deconz/Phoscon?

    Viele Dank!!!


    VG

  • Nastra


    Da bin ich froh, dass ich nicht alleine bin mit meiner temporären Vergesslichkeit.

    Ich habe mir angewöhnt so etwas immer als Pdf- oder txt-Datei abzuspeichern.

    Wo ich das her habe weiß ich nicht mehr, aber ich stelle es, so ich es darf, als Anhang hier mal ein.

    Ist für einen Conbee, sollte aber auch für den Raspbee gehen.

  • Spy

    Vielen Dank- ich nehme es mir jedes Mal vor und wenn es dann irgendwann und irgendwie geklappt hat, gerät eine saubere Dokumentation in Vergessenheit.

    Nach deconz dann homebridge nach der hier verfügbaren Anleitung, damit die Zigbee Devices ins HomeKit gelangen?!

  • Spy ok, also Image noch mal neu auf Raspi, deconz nach Phoscon Anleitung installiert, homebridge nach der Anleitung hier und das homebridge-hue Plugin - allerdings öffnet sich jetzt das Einstellungsfenster und ich will alles richtig machen und nicht noch mal installieren.

    Also hier die Frage: bei Bridge kommt die ip des Pi rein, welcher Port? 8080 also z.b. 192.168.1.90:8080

  • Spy noch eine Frage, brauch ich noch das deconz Plugin? Wie wird denn deconz jetzt noch gekoppelt mit homebridge? Wenn ich das richtig verstanden habe, muss ja in die config.json noch was eingetragen werden?!

    Vielen Dank für die Unterstützung!

  • Spy also ich habe bestimmt ne Woche verschiedenste Anleitungen probiert und Zack :):thumbup: meine Woche ist gerettet! Vielen Dank-

    Eine abschließende Frage: Im Moment starte ich alles manuell, also deconz, dann homebridge und muss jedes Mal noch über Phoscon das Gateway verbinden- kannst du mir bitte noch sagen, was ich für die Automatisierung der Schritte machen kann?!

  • ALso, wenn Du alles nach der Anleitung von hier (Sschuste) gemacht hast sollte die Homebridge automatisch starten.

    Am Ende meiner verlinkten Anleitung steht doch auch wie Deconz automatisch startet.

    Code
    1. sudo systemctl enable deconz-gui

    Damit startest Du das GUI


    und dann wählen

    Code
    1. sudo systemctl enable deconz.service
    2. und
    3. sudo systemctl disable deconz-gui.service
    4. Wenn du deCONZ mit Gui betreiben möchtest dann
    5. disable und enable in beiden Befehlen
    6. gegeneinander austauschen.
  • Spy den Part habe ich dann wohl übersprungen, weil zunächst nicht für wichtig erachtet :saint: aber danke für Deine Geduld und den erneuten Hinweis.


    ich hätte noch ne Frage. Ich habe einen Multisensor von Aqara integriert. Es werden auch beide Werte (Temp, Luftfeuchtigkeit) angezeigt. Allerdings wird im Status nur die Luftfeuchtigkeit angezeigt, nicht die Temperatur, obwohl es bei den Einstellungen aktiviert ist.