HomeKit Automation funktioniert nicht

  • Ich hänge mich da nun auch mal mit dran, denn ich habe hier auch so meine Probleme mit der Automatisierung über die Home App.


    HomeBridge läuft auf einen Mac mini, iPad ist die Home Zentrale, mein iPhone und das iPhone meiner Lebensgefährtin sind als eingeladene Personen im Haus drinnen. Neuste iOS und macOS ist auf den Geräten drauf.

    • Mac mini und iPad haben die gleiche Apple ID (Gemeinschafts ID von meiner Lebensgefährtin und mir), diese ID ist auch der Familien Organisator.
    • Mein iPhone, hat meine ID und ich bin in der Familie drinnen und darf auch ein Käufe Freigeben.
    • iPhone meiner Lebensgefährtin hat ihre eigene ID und ist auch in der Familie drinnen.


    So nun habe ich 6 Szenen

    • Guten Morgen
    • Gute Nacht
    • Illumination
    • Gaming
    • Zu Hause erreichen
    • Zu Hause verlassen


    Die Szenen Funktionieren auch, wenn ich sie einzeln schalte gehen die entsprechend Lampen an bzw. aus. Nur in Kombination mit der Automation funktioniert es nicht.


    1. Automation

    13:30, täglich Nur wenn jemand zu Hause ist soll die Szene "Illumination" geschalten werden.


    So, hier habe ich nun das Problem, das ich nicht bei Personen nun die Gemeinschafts ID rausnehmen kann, das heißt natürlich das nun um 13:30 die Szene geschalten wird ob wohl weder meine Lebensgefährtin noch ich daheim sind. Denn das iPad liegt ja daheim...



    2. Automation

    Wenn die letzte von 2 Personen zu Hause verlässt, soll die Szene "Zu Hause verlassen" geschaltet werden.

    (Hier kann ich die ID von iPad rausnehmen, so das eben nur 2 Personen und nicht 3 Personen diese Automation auslösen könnten)


    Das hat nicht funktioniert, von unterwegs habe ich nach geschaut und die Lampen waren immer noch an... So habe ich diese dann von Unterwegs abgeschaltet. Später habe ich dann auch nach geschaut ob die Lampen noch aus sind und es waren sie. Als ich dann noch mal nach 13:30 geschaut habe, waren die Lampen an. Denn Automation 1 hat diese nun geschalten, da ich wie oben schon beschrieben ja die Gemeinschafts ID nicht rausnehmen kann und das iPad ja daheim liegt. Also habe ich die Lampen wieder abgeschaltet. Nun sind sie auch aus geblieben bis wir daheim waren.



    3. Automation

    Wenn die erste von 2 Personen zu Hause ankommt, soll die Szene "Zu Hause erreichen" geschaltet werden.

    (Hier kann ich die ID von iPad rausnehmen, so das eben nur 2 Personen und nicht 3 Personen diese Automation auslösen könnten)


    Das hat es nicht gemacht, als wir die Wohnung betreten haben, sind die Lampen dunkel geblieben...

  • Hallo ...


    ich habe mit der Automatisierung auch so meine Probleme, obwohl es machmal klappt.

    Seltsamerweise ...

    Ich habe in meiner Logitech Harmony die Aktion Surround und PS3.

    Wenn ich eine von den beiden Aktionen starte, soll der Subwoofer über eine Funksteckdose

    an bzw. aus geschaltet werden.

    Das klappt über den Schalter Subwoofer aber nicht über die Automatisierung ...?


    CU Kai

  • Hilft zwar nicht wirklich weiter aber … Ich habe mein HomeKit seit Beginn schon mehrere male wegen Problemen zurückgesetzt und komplett neu aufgebaut. Stöhn! || Momentan läuft bei mir nur ein reduziertes Setup da das komplette Einrichten immer sehr zeitintensiv ist. So habe ich nur noch schlanke drei Regeln. Zwei davon mit Ortungsdienste (Anwesenheit). Mehr nicht. Was soll ich sagen … Mal klappt es, mal nicht … mal hilft es die Regeln zu löschen und wieder neu zu erstellen. Das funktioniert dann vielleicht paar Tage. Irgendwann halt nicht mehr.

  • Ist nicht wirklich zufriedenstellend... würde mich halt wirklich Interessieren ob es an Home liegt oder doch eher an der Homebridge. Da muss ich ganz ehrlich sagen da läuft die Anwesenheits Erkennung über iConnectHue deutlich besser.


    Ist nur schade, das man eigentlich doch mehre Apps benötigt damit alles so funktioniert wie man es gerne hätte...

  • Bei mir ist es ganz klar Homekit. Ich habe die Probleme auch ohne die Homebridge. In meinem reduzierten Setup habe ich sie momentan gar nicht eingebunden. Ich werde es aber wieder aktivieren.


    Übrigens die Anwesenheitserkennung über iConnectHue und Homebridge läuft bei mir absolut zuverlässig. Probleme machen bei mir nur die HomeKit Regeln.

  • Auch ich habe Probleme mit der Automation über HomeKit.

    Mein Setup:

    Philips Hue mit mehreren Lampen, Bewegungsmelder, Switch.

    Koogeek Steckdosen

    Tado Thermostatköpfen.


    iPad mit iOS 10.3.3 (neuer geht nicht mehr) als Steuerzentrale.

    iPhone 6s mit iOS 11.0.3


    Ich habe ein Bewegungsmelder in der Küche, diesen habe ich mittlerweile über die HueApp konfiguriert, da es mit HomeKit nicht so schön einzustellen ist. Bei Bewegung Lampe einschalten und nah einer Zeit wieder Abschalten. Dies klappt hervorragend über die HueApp.


    Die Automation ist eingestellt auf:

    Wenn Küchenlampe AN dann schalte Steckdose (Arbeitsflächenbeleuchtung (Koogeek)) AN.

    Wenn Küchenlampe AUS dann schalte Steckdose AUS.


    Mal klappt es mal nicht. Einfach willkürlich. Ich freue mich schon jedesmal wenn es mal klappt. Man kann sich ein süß drauf machen...

    Naja eigentlich frustet es langsam, denn mal klappt nur AN, dann mal nur AUS, mal beides. Wie es gerade will.

    Das finde ich sehr schade.

    Ich habe gesehen das es eine andere Home App gibt die hier vorgestellt wird, würde es damit besser gehen?

    Die App sieht generell nicht schlecht aus, allein wegen den doppelten Bedingungen.

    Ich habe als nächstes vor eine Homebringe auf Pi Basis einzubinden und die Dashbuttons zu nutzen.


    Ansonsten so toll das auch alle ist finde ich es sehr schade das gerade die HomeKit App so schlecht läuft, das bin ich von Apple nicht gewohnt.

  • Das wird eine andere app leider nicht ändern.


    Auch bei mir klappt es alles nicht immer. Meist geht die Flur lampe per bewegungsmelder an, mal nicht.. kann aber auch mal wieder an homebridge/pilight liegen.

    Wer nicht mit der Zeit geht, muss mit der Zeit gehen 8o

  • Wie und wo kann ich die ID vim iPad rausnehmen? Habe ich noch nicht entdeckt.

  • klinke mich auch mal ein und bin so kühn zu behaupten, die Automatisierungsprobleme liege am 11-er ios update.


    vor dem update bei mir alle regeln, Szenen ok, nachdem update -> grausam.


    natürlich alle Szenen neu erstellt. trotzdem.


    das 11-er update hat sich definitiv auch auf die Eve app ausgewirkt (keine anzeige mehr, wann ein Szene ausgelöst wurde), "Volker" von elgato bestätigt das und will das für ein nächstes update melden.


    oder... wenn man mehrere geräte als steurzenrale hinterlegt hat(-te), so ist ab dem iOS 11 nur noch genau eins möglich. zumindest interpretiere ich so, wenn ich in der HK app unter HAUS , dann oben links geklickt, die Auflistung der hinterlegten steuerzentralen sehe und weitere geräte (atv´s oder iPad´s) als "Standby" angezeigt werden UND...man kann nichtmal einstellen, WELCHES gerät nun als primäre steuerzentrale dienen soll. oder kann zufällig jemand sagen, ob das vor iOS 11 auch der fall war ?


    oder... vorher plugin peoples super stabil und genau gelaufen, jetzt melden sich die handy´s im Sekundentakt , na gut, Minutentakt, bei HK an und ab und somit schalten natürlich hinterlegte Szenen im minutentakt an/aus. und da offensichtlich de Eve-app ziemlich betroffen ist, sind hinterlegte Szenen mit Heizungsplänen für die Heizungssteuerung eher... NICHT mehr möglich. das gilt übrigens auch, wenn man von people auf geo Anwesenheitserkennung umgestellt hat.


    vlt. bin ich auch zu unwissend.

    aber da ich aber eh gerade in andern homekit Projekten bin, hab ich alles auf "manuell" gestellt und hoffe derweil auf ein echtes update von homekit und nicht auf weiter 20 neue emoji´s wie jetzt bei 11.1

  • Bedingt durch die Unzuverlässigkeit habe ich testweise alles zurückgesetzt und meine Geräte, Regeln und Szenen stark reduziert. Auch die Homebridge ist erst mal nicht dabei.


    Momentan laufen die wenigen Regeln recht zuverlässig. Nur die seit iOS 11 eingeführten neuen Geofencing-Regeln machen Probleme. Also die wo mehrere Personen berücksichtigt werden (letzte Person verlässt das Haus; erste Person kommt am Haus an). Die werden einfach ignoriert. Gebe ich als Ort nicht "Haus" an sondern direkt einen Standort dann klappt es. Nur leider geht dies nicht mit mehreren Personen.

  • @jluetgen


    das hört sich nach einer durchaus (wenn auch leidvoll) fundierten erfahrung an.


    also meinst du im ernst, alles OFF, alles NEU ?


    da werd ich ja "irre", nur weil die updates nicht sauber gemacht sind. ist ja wie bei microsoft !



    2 fragen, wenn du das zuverlässig sagen kannst, denn dann müsste ich es nicht ausprobieren, bequem wie man(N) ist :saint:


    nutze auch 2 x atv4 + 1 x ipad. also bist du dir sicher, dass die sozusagen "automatisch" switchen würden, falls das "primäre" z.b. einfach mal "defekt" wäre ?


    die als zentrale hinterlegten geräte (ob nun ON oder nur im STANDBY) haben aber nach wie vor die eigenschaft der reichweitenverlängerung?

  • Ich habe es sogar hinbekommen, wenn die Aussentemperatursensor (Eve Weather) unter 13 Grad erreicht, die Heizungen eingeschaltet werden. Meine Grundtemperatur Nachts und wenn niemand zu Hause ist ist 13 Grad. Sollte Jemand zu Hause ankommen, werden die Gemeinschaftsräume (Küche und Bad) auf 17 - 20 Grad gebracht und z.B. auch das Kinderzimmer meiner Tochter geheizt. Gleichzeitig halten sich die automatisierten Regeln an den in Eve Thermo vorgegebenen Zeitplan. Verlässt meine Tochter das Haus, wird alles wieder auf 13 Grad gestellt - Öffnet sie ihr Fenster, oder Ihre Balkontür, geht ihre Heizung im Kinderzimmer aus.


    Die Messung von Eve Weather stellt man am Besten in der Eve App ein, da HomeKit das Gerät leider nicht als Sensor erkennt - weiter gehts dann mit HomeKit. Bedenke das Eve leider die Regel nicht mehr listet, denn man Bewegungsdaten in HomeKit hinzugefügt hat. Mit einem Update von Elgato sollten die Regeln, laut Volker, wieder in der EveApp sichtbar ein.

    Du verwendest nur Elgato Geräte?

    Mein Beispiel programmiert im HomeKit: der Hue Dimmer schaltet mit der Taste 1 eine Hue Lampe und eine Elgato Steckdose ein. Das funktioniert fallweise. Die Hue Lampe geht immer an, die Steckdose selten. Schalte ich die Situation auf der Home App ein, funktioniert sie. Schalte ich die Situation mit der Dimmertaste ein, tritt das Problem auf. Habe ich die Home App geöffnet, kann ich sehen, dass die Taste am Dimmer gedrückt wird. Also offensichtlich liegt das Problem in der Cloud.

  • Ich habe es sogar hinbekommen, wenn die Aussentemperatursensor (Eve Weather) unter 13 Grad erreicht, die Heizungen eingeschaltet werden. Meine Grundtemperatur Nachts und wenn niemand zu Hause ist ist 13 Grad. Sollte Jemand zu Hause ankommen, werden die Gemeinschaftsräume (Küche und Bad) auf 17 - 20 Grad gebracht und z.B. auch das Kinderzimmer meiner Tochter geheizt. Gleichzeitig halten sich die automatisierten Regeln an den in Eve Thermo vorgegebenen Zeitplan. Verlässt meine Tochter das Haus, wird alles wieder auf 13 Grad gestellt - Öffnet sie ihr Fenster, oder Ihre Balkontür, geht ihre Heizung im Kinderzimmer aus.


    Die Messung von Eve Weather stellt man am Besten in der Eve App ein, da HomeKit das Gerät leider nicht als Sensor erkennt - weiter gehts dann mit HomeKit. Bedenke das Eve leider die Regel nicht mehr listet, denn man Bewegungsdaten in HomeKit hinzugefügt hat. Mit einem Update von Elgato sollten die Regeln, laut Volker, wieder in der EveApp sichtbar ein.

    @jluetgen


    Nehme dazu gerne mal paar Screenshots.


    Ich habe aktuell 4 Eve Thermostate verbaut. Die optimale Einstellung habe ich noch nicht.

  • :-) ich trau mich (noch) nicht :-)

  • Bist du da schon weiter? Vorher hatte ich die Lightify-Plugs in der Hue-App und da ging es mit den Bewegungsmeldern super. Nun bin ich auf Koogeek umgeschwenkt und nun geht das Licht zwar an, bleibt aber bei Bewegung nicht an. Wie kann man das ändern? Habe auch die teurere Home-App.

    Kann man die Koogeek-Steckdosen auch in die Hue-app integrieren?