homebridge-blinkcameras​

  • Nabend!


    Ein Upgrade meines Plugins homebridge-blink hat mich gestern fast zur Verzweiflung gebracht.

    Nach einem Upgrade des Plugins ist die Homebridge nicht mehr gestartet...


    Während des Installationsvorganges kommt diese Meldung. Was bedeutet sie genau und was wäre die Lösung, um das Plugin weiter in der aktuellen Version nutzen zu können?


    Hat es was mit node zu tun?

    Ich habe bereits verschiede Versionen erfolglos getestet.

    Aktuell bin ich bei 10.16.3.


    Code
    1. "npm WARN deprecated [email protected]: [email protected]<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of [email protected]"
  • Ich vermute das hat mit deinem System nichts zu tun. Der Entwickler des Plugins müsste da nachbessern und die Dependencies des Plugins aktualisieren. Ich bekomme die gleiche Warnung beim homebridge-homewizard Plugin. Funktioniert aber trotzdem (noch).

  • Es ist übrigens das plugin "homebridge-blinkcamera", das nur zur Korrektur...


    Ohne Update funktioniert das Plugin noch, ja.

    Aber das würde bedeuten, dass ich das Plugin nie wieder updaten kann ohne mein System zu zerstören?

    Oder verstehe ich euch richtig, dass das Update scheinbar fehlerhaft ist und in ein paar Wochen oder wann auch immer korrigiert sein könnte?


    Für mich ist dieses Plugin sehr wichtig, da es meine Cams integriert, ich möchte nur gerne vorbereitet sein.


  • Aber das würde bedeuten, dass ich das Plugin nie wieder updaten kann ohne mein System zu zerstören?

    Könnte sein.

    Oder verstehe ich euch richtig, dass das Update scheinbar fehlerhaft ist und in ein paar Wochen oder wann auch immer korrigiert sein könnte?

    Könnte sein.


    Ich denke, du musst dir keine Sorgen machen. Die Warnung ist ja nicht nur eine Warnung, sondern sie enthält auch noch Inhalt, der mithilfe von https://www.deepl.com/translator sichtbar gemacht werden kann:


    "npm WARN veraltet [email protected]: [email protected]<3 wird nicht mehr gewartet und aufgrund der Anzahl der Probleme nicht mehr für die Verwendung empfohlen. Bitte aktualisieren Sie Ihre Abhängigkeiten auf die aktuelle Version von [email protected]"


    Die alte Version von core-js, die von homebridge-blinkcamera verwendet wird, wird nicht mehr zur weiteren Verwendung empfohlen. Da muss der Entwickler von homebridge-blinkcamera ran, du kannst da wahrscheinlich nichts machen. Die Warnung sagt nicht aus, dass die alte Version von core-js verschwindet. Am besten eröffnest du ein Issue auf GitHub und fragst den Entwickler einfach.


    Stefan

  • Hallo zusammen, ich benötige Hilfe bei der Installation des Plugins: Homebridge-Blinkcameras


    Installiere ich es über Homebridge Config UI X, lässt es sich zwar installieren, allerdings erhalte ich eine Syntax-Fehlermeldung in der Config.json.


    Installiere ich es über das Terminal als Root, erhalte ich ebenfalls eine Fehlermeldung, jedoch eine andere:


    Wer kann mir helfen bei der Installation?

  • Installiere ich es über das Terminal als Root, erhalte ich ebenfalls eine Fehlermeldung, jedoch eine andere:

    Da ist keine Fehlermeldung. Die beginnen nämlich mit dem schon fast poetisch zu nennenden Wort ERROR. Dies ist eine Warnung, im Sinne von, "eh sieh dir das mal an". Am Ende ist das Plugin installiert.


    Nur leider falsch.


    Der Befehl zur Installation lautet: npm i -g homebridge-blinkcameras. Das -g ist sehr wichtig. So wird das Plugin nämlich dorthin installiert, wo auch die anderen Plugins sind und nicht in irgendein Homeverzeichnis, wo es nix zu suchen hat. Ich würde das sogar noch erweitern zu einem npm i -g --unsafe-perm homebridge-blinkcameras

  • Hallo und vielen Dank für den Hinweis, dadurch konnte ich das Plugin via ssh als root installieren.


    Leider kommt es aber bei der Bearbeitung der config.json weiter zu besagten Syntax-Fehler. ich denke eigentlich, dass ich alles korrekt eingegeben habe, könnte das bitte jemand bestätigen? (email und password beim BlinkCamera - Plugin sind in echt korrekt eingegeben.


    Homebridge Blinkcameras Link


    Offenbar habe ich den Fehler gefunden. Nachdem ich diese Zeile entfernt habe, lies sich die config.json abspeichern.


    Zitat
    Code
    1. // optional: set to false to disable intermittent discovery

    Ich hatte anfangs nach dem Update auch Probleme mit der neuen Plugin Version 0.21. Kann jetzt aber bestätigen das ich keine Fehlermeldung mehr erhalte. Das Plugin funktioniert bei mir. Für einen Langzeittest ist es noch zu früh.