HomeKit und Bewegungsmelder - geht nur manchmal

  • Servus zusammen,


    Ich hab da ein Problem mit HomeKit und Aqara BWM, teilweise auch mit den Hue BWM.


    Meine Automationen sind eigentlich recht simple, aber sie gehen einfach nicht, wie ich will.


    Z.b. Schalte Szene tagsüber, wenn jemand da ist und Helligkeit unter 45lx ist und schalte nach 2 Minuten aus.


    Wenn denn mal das Licht an ist, dann geht es selten aus, was mich dazu gebracht hat ein Script in ioBroker zu schreiben, dass die Lampen nach einer definierten Zeit abschalten, wenn keine Bewegung mehr erkannt wird. Bei Bewegung wird der Timeout gestoppt, keine Bewegung Timeout gestartet.


    Heute als Beispiel ging die Lampe den ganzen Tag an wie sie soll, gegen Abend gehen die Lampen plötzlich nicht mehr an. In HomeKit wird mir die Bewegung angezeigt, die Lampe bleibt aber aus. Erreichbar ist die Hue-Lampe, daran kann es nicht liegen.


    Eine zweite Automation soll nur nachts und wenn jemand da ist einschalten bei Bewegung. Geht eine zeit lang, dann geht es plötzlich gar nicht mehr. Auch hier: Bewegung wird erkannt (in der Home App angezeigt, aber das Licht bleibt aus).


    Manchmal hilft es die Automation zu öffnen und neu zu speichern, aber, wie gerade, hilft nicht mal das.. Ich muss die Automation dann löschen und neu anlegen.


    Zentrale ist entweder Apple TV oder HomePod. Die wechseln sich immer wieder mal ab. Warum auch immer..


    Hat jemand eine Idee? Meine Scripte zum ausschalten laufen einwandfrei.


    Danke und Gruß,

    brasax

  • Hi,


    wie sind denn deine Automationen genau gebaut? Nutzt du die Funktion "automatische Deaktivieren nach X Minuten"? Haben die Automationen einen Tagwechsel (als Zeitbedingungen) drin? Ich habe sowohl für Bewegung als auch für keine Bewegung mittlerweile eigene Automationen erstellt, dass funktioniert (zumindest bei den Aqara Sensoren) bei mir besser mittlerweile.

  • Hier mal Screenshots. Simple Automation. Das automatische Deaktivieren mache ich über den ioBroker, da es in HomeKit nicht zuverlässig funktioniert und teilweise dann den ganzen Tag/Nacht das Licht an ist.


    Tagsüber habe ich noch drin, wenn kleiner 45lux. Das Ganze über Contoller angelegt.

  • Hi,


    schaltest du mit den Sensoren zufällig erst Shellys?


    Hatte das gleiche Problem, habe die Shelly geupdatet und zusätzlich eine Verknüpfung eingebaut, das nur ein Ein-Befehl rausgeht, wenn die Lampen tatsächlich aus sind. Ich wollte damit vermeiden, dass die Lampen ständig nachgetriggert werden. Bei dem Aus-Befehl das gleiche vorgehen.


    Funktioniert jetzt einwandfrei.


    Ich nutze Hue BWM - Decons - Shelly 1 bzw Shelly Dimmer.


    VG

  • Hier mal Screenshots. Simple Automation. Das automatische Deaktivieren mache ich über den ioBroker, da es in HomeKit nicht zuverlässig funktioniert und teilweise dann den ganzen Tag/Nacht das Licht an ist.


    Tagsüber habe ich noch drin, wenn kleiner 45lux. Das Ganze über Contoller angelegt.

    Ob die Logik in iobroker sich irgendwie beißt, kann ich nicht beurteilen. Jedoch kannst du mal versuchen, einfach ebenfalls eine Automation "Wenn keine Bewegung erkannt wird" einzustellen.

  • Die Automation im ioBroker beißt sich nicht, schon geprüft. Dort läuft diese erst, wenn der Status sich auf Bewegung = false ändert. Das Problem tritt auch auf, wenn ich das Script stoppe und die Lampe manuell ausschalte.


    41VSY

    Keine Shellys dazwischen. Nur der Aquara Sensor und Hue-Bulb.


    Was mich ja irritiert, in der Home-App wird die Bewegung erkannt, aber die Lampe schaltet nicht.


    Ging jetzt eine Stunde lang nicht und jetzt wieder. Ich verstehe es nicht.

  • Hilft dir nur bedingt, aber ich habe im Haus hier alle BWM direkt von und in Hue mit unterschiedlichen Reaktionen tags und nachts und am We. Hatte vorher auch Aqara und stand da häufiger im Dunkeln.

    Ist aber kein Problem der Aqara sondern der Automation, da die Bewegung ja in den Sensoren erkannt wird. Dementsprechend hilft die Aussage nicht nur bedingt, sondern gar nicht.

  • Ich habe das Problem auch, aber nicht so gehäuft, mit den Hue BWM.


    Da scheint HomeKit einfach zu zicken, denn, wie schon erwähnt, in der Home App wird die Bewegung angezeigt, aber es passiert nichts.


    Nachts habe ich die Helligkeit bei 34%, manchmal passiert es allerdings am Tag auch hin und wieder, dass das Licht mit 34% angeht und nicht die Szene aktiviert wird (mit 100%). Geht man eine halbe Stunde später wieder rein, dann greift die Szene plötzlich.


    Ich mach inzwischen recht viel im ioBroker, aber da gibts leider kein adaptives Licht. Daher in HomeKit.

  • Also hatte die Kombination:


    Homekit / eve automation:

    - Hue Beleuchtung

    - Hue Bewegungsmelder


    War schöner einstellbar und dimmbar, hat aber andauernd nicht funktioniert!

    Das ist bei mir noch an der grenze, hat aber die Frustrationsgrenze meiner Frau schon deutlich überschritten!

    Wenn hier einmal ein Dimmschalter nicht bei dem ersten druck geht, bekomm ich schon wieder ärger :D.


    Bin dann auf die Hue Essentials app umgestiegen (iconnect hue finde ich zu unübersichtlich habe ich aber auch)

    Hier sind die Einstellmöglichkeiten nicht so weitreichend, dafür funktioniert es aber deutlich besser, wenn die Hue Bridge alle Informationen verarbeitet.


    Bei mir also identisches verhalten! Die Homekit Automation mit dem Bewegungsmelder hat nicht immer geschaltet!

  • Ärgerlich. Dann werde ich wohl doch die BWM über ioBroker steuern und entsprechend den Tag in verschiedene Helligkeiten/Töne einrichten müssen. Hatte gehofft das vermeiden zu können. Ich fand die Idee mit dem adaptiven Licht ziemlich gut, aber wenn es denn nicht wirklich funktioniert..

  • Ich hab das Gefühl, dass HomeKit phasenweise nicht funktioniert.


    Heute ging mal wieder das Licht in der Küche nicht an - bin hoch ins Bad und die Lichter im Gang gingen ebenso nicht an, auch nicht im Bad. Überall sind BWM, Aqara und Hue.


    Auf dem Weg zurück ging das Licht unten im Gang (oben nicht) und dann auch wieder in der Küche..

  • Ich muss mich hier auch mal einklinken.


    Mein Problem ist, das der hue BWM nicht mehr per HomeKit App und hue erreichbar ist, aber bei hue essentials schon. Es werden sogar die Werte angezeigt. Nur erreichbar ist er nicht mehr.

    Dadurch schaltet sich mein Garagenlicht nicht mehr automatisch.


    Woran kann das liegen?

  • Moin Moin mjrO89,


    Das werden die letzten Werte sein die er erfasst hat.


    Ansonsten solltest du dich fragen:

    - Ist Batterie leer?

    - Ist er außer Reichweite Bzw. Im Grenzbereich? Sodas er nur ein sehr geringes Signal bekommt das zeitweise abbricht. Umwelteinflüsse könnten dafür sorgen dass das Signal das bisher gerade so ausreichte jetzt nicht mehr genügt.


    Es könnte auch helfen ihn einfach mal zurückzusetzen und neu anzulernen.


    Dampf

  • Liegt eventuell an der neuen HUE App. Ich musste ein paar

    Geräte erneut in HUE einbinden.


    LG

  • Liegt eventuell an der neuen HUE App. Ich musste ein paar

    Geräte erneut in HUE einbinden.

    Das könnte sein. Ich musste nämlich einen meiner Motion Sensors auch neu einbinden - was mir nach jahrelangem reibungslosen Betrieb schon merkwürdig vorkam. An das App-Update habe ich gar nicht gedacht.

  • Er war schon 1 Tag nicht erreichbar, aber letzte Bewegung vor einer Stunde erkannt.


    Sehr merkwürdig. Batterie war voll, und Reichweite ca. 1 Meter vom AP und der Bridge entfernt.


    Liegt eventuell an der neuen HUE App. Ich musste ein paar

    Geräte erneut in HUE einbinden.


    LG

    Das kann echt sein da er jetzt nach 3 Tagen einfach wieder erreichbar ist.


    Leider ist das Rätsel dadurch nicht gelüftet.